PDA

View Full Version : webspace and web.scu problem


janhar
06-04-2010, 08:50 AM
Hello

I have instaled webspace in the same computer that SCADA is on. I can already connect with browser from client to server and successfully login with my username and password. But then in the browser message pops up and tells me
"cannot start SCADA from a browser session".

I think there is a problem with web.scu
Because when i configure my projects *.scu and web.scu it just automaticly takes NODENAME form projects.scu to web.scu and i cannot add network remote node to web.scu because there is the same on both SCUs. (u cannot make connection at yourself :) ).

What to do?

Thanks

Sonny
06-07-2010, 11:38 AM
In webspace, there are 2 versions of server.

1. You install WBS on an iFix scada, and it can server data ONLY from that scada.
2. You run WBS as a View Developer, and this allows you to connect to multiple scadas in the remote node list.

So, which version did you purchase?

In version 1, the SCADA SCU is also the SCU that WBS uses

In version 2, the View Developer node installed on the WBS server is also the SCU that WBS users.


Hope this helps,
Sonny

janhar
06-09-2010, 09:19 AM
I am trying 2. version now, because this is the one that is needed.

I have 3 computers...
1. On the first one there is ifix project name TEST
2. On the second one there is webspace server
3. On the third one there is clinet that access to the web server

On 1. comp (192.168.1.40) i have
LOCAL NODENAME: TEST
LOCAL LOGICAL NAME: TEST
c:\dynamics\test\local\test.scu
DATABASE NAME:TEST

SCADA is enabled
network is enabled - tcp/ip with no remote nodname
Ifix is running

On 2. comp (192.168.1.90) i have
LOCAL NODENAME: WEB
LOCAL LOGICAL NAME: WEB
c:\dynamics\local\web.scu
DATABASE NAME:empty

SCADA is disabled
network is enabled - tcp/ip with nodname TEST
Ifix is not running

On 3. comp (192.168.1.50) i have
browser mozilla to access to the web server *.*.*.90 with
http://192.168.1.90/ifixwebspace/

I have the same username and password on all 3 computers
User have administrator rights.
I also enabled iFix security with the same username and password on 1. and 2. computer
I also put
192.168.1.40 TEST
in C:\WINDOWS\system32\drivers\etc in file named HOSTS

In browser there is a logging windows that pops up, i put in username and password and than message "cannot start SCADA from a browser session" pops up.

That's it...

Sonny
06-11-2010, 10:27 AM
On the Web server:
1. This Fix node needs to be configured as a View Developer, and should not have scada support enabled on it.
2. You should be able to run iFix on this machine, and do standard view developer functions with this scu.
3. Once you have this working, you can use this SCU as the Launch command in iFix WebSpace Administration. I do not think that iFix has to be running on this node, just the Webspace Server
4. The HOSTS file on this machine needs to have the scada node name in it
192.168.1.40 TEST
5. Dynamic Connections need to me enabled


On the Scada:
1. The HOSTS file on this machine needs to have the WEB node name in it
192.168.1.90 WEB
2. Dynamic Connections need to me enabled


On the WebClient:
1. It is not necessary to have any entries in the HOSTS file, pointing to either WEB or TEST (unless you want to resolve WEB's node name in the URL, eg: HTTP://WEB/iFIXWEBSPACE) on that client

janhar
07-06-2010, 02:19 AM
Ok, it's workng now, i had to put scada nodename in web server. tnx sonny